Account creation disabled
Incident Report for Quantive
Resolved
The incident has been resolved
Posted Jun 21, 2019 - 09:00 UTC
Investigating
We are currently investigating an issue that prevents new users from creating accounts.
Posted Jun 21, 2019 - 08:40 UTC
This incident affected: Results EU (Timeline API).